[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 574: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 630: sizeof(): Parameter must be an array or an object that implements Countable
Build Your Own SLA/SLS • NanoDLP and the LittleRP2
Page 1 of 1

Re: NanoDLP and the LittleRP2

Posted: Mon Jun 05, 2017 6:01 pm
by Jaidek
Hey Achingbrain,

I recently got NanoDLP working on my LittleRP2 Extended with the help of Brad. Here are some screenshots of the settings I am currently using. For some reason on my Raspberry Pi 3 I have to unplug/plug in the LittleRP2 via USB, then refresh the setup screen for it to connect via Ramps. I am not sure what is going on there, but it happened on both a Raspberry Pi 2 and 3.

Also, when you connect the default Z-Axis buttons don't play very nice with the RP2 (due to NanoDLP using pulses). So you might want to add a few buttons on that screen to control.

Setup:
Image

Example profile:
Image

Custom Buttons:
Image

Hope this helps!

Re: NanoDLP and the LittleRP2

Posted: Thu Sep 13, 2018 12:14 am
by jborrel00
These settings helped connect me to the RAMPS board on my littleRP but I haven't managed to properly control a print. The projector turns on and off accordingly, but the platform doesn't move. Any idea what I might be doing wrong? I've got a different build of NanoDLP running on my Raspberry Pi 3, so some of the settings options are a little different.