Help Needed on controlling Z axis motion

Here is the place to discuss software and related tools for Slice generation, machine control, & etc...
CwBeebop
Posts: 1
Joined: Fri Apr 21, 2017 7:50 pm

Help Needed on controlling Z axis motion

Postby CwBeebop » Fri Apr 21, 2017 8:07 pm

Hello everyone,


I am following this 'Chimera' $60 printer guide for the construction of a DLP 3D printer and i ran into couple of problems. I tried searching online for answers but got no solution, so I am hoping someone here can set me straight.

I am using a DVD rom drive with stepper motor as my linear motion set-up. I have paired this up with EasyDriver, Arduino UNO and GRBL.
Here are some of the pics i have used for setting up my system IMG

When I plug it in, the power light on the easydriver turns on, but I can't get the stepper motor to move at all. The guide I am following walked me through putting GRBL firmware on the arduino and using GRBLcontroller to control the z-axis, but I get no response. The software does connect to the UNO, and allows me to write data to it, as far as I can tell.

I have also opened Creation Workshop and set it to the appropriate COMM port and tried to use the control tab to get the stepper motor to turn, with no luck.

In addition, i am unable to connect CW with GRBL, the connection port doesn't turn grey when i try to connect it. I have confirmed that the baud rate is set correctly at 115200 and connected to the correct COM port.

Right now i'm running out of ideas to troubleshoot, any help would be much appreciated.

What can I try for troubleshooting next? I am not sure how to proceed.