..It just wont go down.

Here is the place to discuss software and related tools for Slice generation, machine control, & etc...
mandy
Posts: 13
Joined: Tue Feb 04, 2014 5:13 pm

..It just wont go down.

Postby mandy » Sun Apr 12, 2015 10:23 am

I've been away for a while, now I'm back, I started troubleshooting, which ended with that I starting in scratch again and took to me what was given as proposed earlier.

i loaded the latest marlin firmware, i have only one opto-endstop in the setup, the Z axis will home, but wont go down, this is what i have changed.
#define Z_MAX_POS 200
#define Z_MIN_POS 0
#define DISABLE_MAX_ENDSTOPS
#define DEFAULT_AXIS_STEPS_PER_UNIT {80,80,400,500}

suggestion...?

User avatar
PacManFan
Site Admin
Posts: 633
Joined: Sun Dec 01, 2013 11:44 am
Location: Ahead of the curve

Re: ..It just wont go down.

Postby PacManFan » Sun Apr 12, 2015 11:28 am

Try adding in an endstop z-limit switch.

mandy
Posts: 13
Joined: Tue Feb 04, 2014 5:13 pm

Re: ..It just wont go down.

Postby mandy » Sun Apr 12, 2015 12:17 pm

PacManFan wrote:Try adding in an endstop z-limit switch.


Not sure what you mean, does it need two (or three) endstops for Z?
however i did this: installed optoendstop (Z_MAX)
//#define DISABLE_MAX_ENDSTOPS

It went home(Up), do not want to go down :(

User avatar
James
Posts: 150
Joined: Mon Dec 02, 2013 1:56 am
Contact:

Re: ..It just wont go down.

Postby James » Sun Apr 12, 2015 1:39 pm

I have zero knowledge as far as software goes regarding Creation Workshop, however, I just wanted to say that there is a situation related to all stepper motor applications where you can have the stepper motor wired wrong and as a result it will only rotate in one direction. If you cannot get it to rotate at all in one of the directions no matter what you try software wise try looking at your stepper motor wiring. It a long shot, but I ran into this problem years ago so it can be worth taking a look.
I prefer to know nothing about everything rather than everything about nothing. :)

mandy
Posts: 13
Joined: Tue Feb 04, 2014 5:13 pm

Re: ..It just wont go down.

Postby mandy » Sun Apr 12, 2015 2:09 pm

James wrote:I have zero knowledge as far as software goes regarding Creation Workshop, however, I just wanted to say that there is a situation related to all stepper motor applications where you can have the stepper motor wired wrong and as a result it will only rotate in one direction. If you cannot get it to rotate at all in one of the directions no matter what you try software wise try looking at your stepper motor wiring. It a long shot, but I ran into this problem years ago so it can be worth taking a look.


im not sure the wireing is not ok, if i set
#define Z_MAX_POS -200

it will go down and stop when enstop Z_MAX is set, however, it wont find home, it just will go down..

gotta try set
#define Z_MIN_POS 200
#define Z_MAX_POS 0
and see whats happens.. :D

User avatar
James
Posts: 150
Joined: Mon Dec 02, 2013 1:56 am
Contact:

Re: ..It just wont go down.

Postby James » Sun Apr 12, 2015 2:46 pm

I see, I see.

If you can get it to move in both directions then you're wired up fine.

Hmmmm.... as for what causing the problem for you I don't know. Keep updating, someone is bond to figure it out.
I prefer to know nothing about everything rather than everything about nothing. :)

mandy
Posts: 13
Joined: Tue Feb 04, 2014 5:13 pm

Re: ..It just wont go down.

Postby mandy » Sun Apr 12, 2015 3:10 pm

James wrote:I see, I see.

If you can get it to move in both directions then you're wired up fine.

Hmmmm.... as for what causing the problem for you I don't know. Keep updating, someone is bond to figure it out.


do you know if its possible to send Gcode commands through CW?

User avatar
PacManFan
Site Admin
Posts: 633
Joined: Sun Dec 01, 2013 11:44 am
Location: Ahead of the curve

Re: ..It just wont go down.

Postby PacManFan » Sun Apr 12, 2015 5:45 pm

mandy wrote:
James wrote:I see, I see.

If you can get it to move in both directions then you're wired up fine.

Hmmmm.... as for what causing the problem for you I don't know. Keep updating, someone is bond to figure it out.


do you know if its possible to send Gcode commands through CW?


Yes, it is possible. In your machine configuration, add the projector controls and the gcode controls. Then in the manual control screen, they will appear.
-Steve

mandy
Posts: 13
Joined: Tue Feb 04, 2014 5:13 pm

Re: ..It just wont go down.

Postby mandy » Mon Apr 13, 2015 5:12 am

PacManFan wrote:
mandy wrote:
James wrote:I see, I see.

If you can get it to move in both directions then you're wired up fine.

Hmmmm.... as for what causing the problem for you I don't know. Keep updating, someone is bond to figure it out.


do you know if its possible to send Gcode commands through CW?


Yes, it is possible. In your machine configuration, add the projector controls and the gcode controls. Then in the manual control screen, they will appear.
-Steve


thanks! i didnt know i needed projector control to be enable to get the gcode screen. I will test it when i come home, hopefully it will response with some answear.